eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

wtorek, 23. lipca, 2019, 15:47

Amiga forum / AmigaOS 4.x / Czerwone Guru

Czytasz wątek: Czerwone Guru

mufa
Nieaktywny użytkownik starego forum

Czerwone Guru wysłany: 2007-09-04 23:56

Dzisiaj nastąpił historyczny moment. Po raz pierwszy od czerwca 2004, czyli od momentu gdy używam AmigaOS 4 zaliczyłem czerwone GuruMeditation. O ile żółte guru, czasami pod OS4 się pojawia i nie jest żadną sensacją o tyle czerwone mało kto widział. Były więc dywagacje czy takowe pod AmigaOS 4 w ogóle istnieje. Po dzisiejszej przygodzie, która jak sądze była spowodowana niezbyt udaną wersją jednej z klas USB dostarczoną w ostatnim update, stwierdzam z cała stanowczością że czerwoene Guru w AmigaOS4 pod A1 to nie mit.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

Czerwone Guru wysłany: 2007-09-05 00:00

@mufa

Jak nie zobacze to nie uwierze.

Odpowiedz

Sasquatch
Nieaktywny użytkownik starego forum

Re:Czerwone Guru wysłany: 2007-09-05 07:31

Prosimy Print Screen, albo foto.

@Gordon Shumway
Tylko czy wtedy nie powiesz, że to fake? )

Odpowiedz

amilech
Nieaktywny użytkownik starego forum

Re:Czerwone Guru wysłany: 2007-09-05 11:06

żeby mieć czerwone guru trzeba wywołać odpowiednią funckję

poza tym dziwne jest, że przy dość dużej liczbie betatesterów os4 zdarzają się takie wpadki

Odpowiedz

konrad
Nieaktywny użytkownik starego forum

Re:Czerwone Guru wysłany: 2007-09-05 11:12

@amilech
poza tym dziwne jest, że przy dość dużej liczbie betatesterów os4 zdarzają się takie wpadki




To nie jest w ogóle dziwne, biorąc pod uwagę wielkość tego projektu. Nawet gdyby było 3 razy tyle betatesterów i pracowali przy testowaniu zawodowo po 8h dziennie, to wszystkich błędów by nie wyłapali, bo się nie da.

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Czerwone Guru wysłany: 2007-09-05 12:04

Klasy HID, jak i masstorage, z lipcowego uaktualnienia rzeczywiście trochę zbyt szybko uwolniły się z pod oka betatesterów, o czym świadczyły liczne skargi na portalach amigowych. Przy mojej myszce Samsunga, objawiało się to tym że losowo mniej więcej raz na 10 bootowań mysz nie działała. Nie byla to jednak sytuacja tragiczna, co najwyżej denerwująca, gdyż trzeba było poświęcić dodatkowe kilka sekund na miękki reset systemu. Wczoraj jednak po raz pierwszy mysz wyłączyła się już podczas dosyć długiej około dwugodzinnej pracy z systemem. Wyskoczył komunikat o błędzie hid wraz z requesterem sugerującym chyba jej zresetowanie (na marginesie komunikat był po angielsku, a dotychczas byłem święcie przekonany że AOS 4 został już zlokalizowany w całości), nie zdążyłem jednak dobrze doczytać ani kliknąć na ten requester, gdyż momentalnie nastąpił reebot i słynne czerwone guru. Po kliknięciu i próbie wczytania systemu, nastapił replay itd, itd. Ostatecznie musiałem użyć twardego resetu. Samo czerwone guru, po czterech latach przerwy, nawet miło było zobaczyć, tym bardziej że mało kto miał to szczęście
Cała sytuacja jest już jednak mniej zabawna i zdecydowanie bardziej niebezpieczna, od zwykłego nie zgłaszania się myszy na starcie. Postanowiłem więc pozbyć się klasy HId z ostatniego uaktualnienia, datowanej o zgrozo na 1 kwietnia i wrócić do wersji z finalnego update.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

Czerwone Guru wysłany: 2007-09-06 11:11

@mufa

> a dotychczas byłem święcie
> przekonany że AOS 4 został już
> zlokalizowany w całości

Jest kilka komunikatow, ktorych nie da sie zlokalizowac - winni sa developerzy,
moze kiedys dopisza do tego lokalizacje, ale czasami jest tez tak, ze po prostu nie
da sie tego zrobic.


Odpowiedz

AmigaOS.pl