eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

sobota, 20. października, 2018, 08:08

Amiga forum / AmigaOS 4.x / XPK

Czytasz wątek: XPK

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-04 12:18

Marudzilem juz wczesniej na temat XAD i XFD, a teraz przyszedl czas na XPK. Skad sciagnac, kompletna, natywna wersje? Niestety na OS4Depot jest niby XPK_user 5.2, jednak nie zawiera biblioteki xpkmaster.library ani katalogu Compressors.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-04 14:36

@Andrzej Drozd

Mam wrazenie ze odpowiadalem juz na to pytanie:

http://forum.exec.pl/posts/list/369.page

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-05 13:38

@Gordon Shumway
@Andrzej Drozd

Mam wrazenie ze odpowiadalem juz na to pytanie:

http://forum.exec.pl/posts/list/369.page




Oj, deżawi. Widac ze niesumiennie wszystko zrobilem. No nic...lecytyna, lecytyna jak to mowia starzy gorale, na starsza czesc mlodosci. Za duzo fantasy o Elfach itd.

:roll:

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 17:45

@Gordon Shumway

OK. Sciagnalem XPK z pierwszego linka ktorego znalazlem w Google, czyli - http://www.amiga-stuff.com/crunchers-download.html

Calosc zainstalowalem instalatorem, dogralem xpkmaster.l.main oraz natywne, dodatkowe kompresory. Kompresory dzialaja, ale od tej chwili...
zawiesza mi sie przy starcie Yam. Zarowno ten z AOS4 i jak pelna wersja 2.5. Po wykasowaniu/zmianie nazwy xpkmaster.library, Yam wraca do zycia. Czy mozesz sprawdzic to u siebie?
Jezeli bedziesz mial podobny problem, to skad mam zdobyc natywna biblioteke XPK?

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 18:53

Yam też mi się zawiesza, co gorsza w przeciwieństwie do takiego AmiGG, jego instalacja, a konkretnie instalacja klas MUI, wyrządziła mi sporo szkód w systemie. Całkiem możliwe że żre się z XPK, nie sprawdzałem tego, obejrzałem z ciekawości nową wersję (a przy okazji kilka grimmów) i szybko powróciłem do SimpleMaila.

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 19:15

Ja uzywam tego samego Yama (i w tej samej wersji) w jednym katalogu, na wszystkich trzech systemach (OS4, OS3, MOS). Z tym ze na kazdym systemie odpalam natywna wersje. Na MOSie 1.4.5 nie mam aktualnie XPK, bede musial sprawdzic, poniewaz na Aminecie jest pelna natywna biblioteka. Na OS3 mam XPK, jednak problemow z Yamem nie ma.

Wspomniales takze o MUI. Ja w AOS4 napewno juz mam nowsze klasy. Chocby w zwiazku wlasnie z Yamem. Byc moze takze cierpi na tym sam AmiGG (?), ktory oczywiscie korzysta z MUI.

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 21:26

Wydaje się że rzeczywiście cierpiał. Archiwum z YAMem 2.5 zawiera kilka klas, z czego moim faworytem knota była The Bar. Choć zazwyczaj nie śledzę rozwoju MUIowych klas, aby nie wpędzać się w niepotrzebne kłopoty, tym razem odpilnowałem wersję z marca, niestety nadal coś było nie tak. Dzisiaj postanowiłem uaktualnić każdą z bodajże 5 klas jakie otrzymałem w pakiecie z YAMem, na najnowsze wersje z czerwca. Na koniec poszło The Bar i po nim właśnie odczułem poprawę. IBrowse i SimpleMail, działają i wyglądają wreszcie tak jak przed instalacją YAMa. Co do AmiGG, to widzę że też mu to pomogło, choć nadal mam do niego zastrzeżenia, nadal mogę zawiesić go na życzenie i to bynajmniej nie emotkami.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 21:30

@Andrzej Drozd

Niestety nie korzytam z YAMa - dawno temu przesiadlem sie na Simple Maila i uwielbiam ten program. Polecam. Co do natywnej XPK to tylko na priva od jakiegos usera Amigi One.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-07-07 21:32

@mufa

No to powoli wyjasnia sie - masz po prostu namieszane w MUI (to jest jedna z wad MUI, IMHO - latwo zaprowadzic balagan w klasach nie stosujac dyscypliny recznej aktualizacji - przydal by sie jakis centralny "update" dla MUI). Ja jako, ze czesto pisze newsy zawsze mam wszystko najnowsze co wychodzi dla MUI - poza HTMLView.mcc, ktora w natywnej wersji dla AmigaOS 4.0 jest bardzo niestabilna. Nie polecam instalacji tej klasy w tej wersji.

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-17 13:24

Wracam ponownie do tematu. No to Panowie, uzytkownicy AONE/mikroAONE, czy wysle mi ktos na priv owa nieszczesna natywna xpkmaster.library, ktorej nie ma w AOS4 Classic?

Jezeli nie ma takiej opcji to co mam zrobic? Polowac na pirackie demo AOS4 ktore swojego czasu wycieklo do internetu? Ma ktos jeszcze jakis inny pomysl?

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-17 14:54

@Andrzej Drozd

A co Ci nie dziala z wersja 68k?

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-17 16:42

Nie dziala. Wlasnie wszystko raz jeszcze sprawdzilem uzywajac GUI ZHXPK. Przy probie pakowania dochodzi do Guru Meditation: 80000003. Probowalem roznych kompresorow.
Guru wywala blad z wszystkimi programami ktore probuja uzyc XPK, np. Yam 2.5 (zarowno beta 2.5 z AOS4 jak i pelna wersja 2.5).

Mam xpkmaster.library w wersji 68k wraz z katalogiem compresors oraz xpkmaster.l.main z OS4Depot.

Nie pozostaje mi nic innego jak uzyc natywnej biblioteki xpkmaster.library i sprawdzic to.

PS. Czy natywna biblioteka XPK, podobnie jak XAD zawiera kompresory wewnatrz siebie (a compresors uzywa tylko do dodatkowych pakowaczek, np GZIP i LZMA z OS4Depot) ), czy korzysta z tych 68k?

Tak czy inaczej jestem w czarnej dziurze jesli chodzi o XPK i smiesznie jest sie przelaczac (jezeli trzeba np. cos spakowac/rozpakowac) na AOS3 lub MOSa.

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-17 20:00

@Andrzej Drozd

Dziwne. Sprawdze u siebie. Z jakiego dokladnie kompresora chcesz skorzystac?

Odpowiedz

Andrzej Drozd
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-17 20:19

@Gordon Shumway
@Andrzej Drozd

Dziwne. Sprawdze u siebie. Z jakiego dokladnie kompresora chcesz skorzystac?





Wszystko jedno, poniewaz kazdy powoduje guru przy ZHXPK. Odpal tez przy okazji Yama ktorego masz razem z AOS4, on tez guruje gdy chce skorzystac z XPK na starcie. Jezeli u Ciebie na klasyku bedzie OK, to moze wystarczy u mnie zmiana wersji bibliotek/compresorow?

Odpowiedz

Gordon Shumway
Nieaktywny użytkownik starego forum

XPK wysłany: 2008-08-18 08:56

@Andrzej Drozd

Przetestowalem i ZHXPK faktycznie wywala guru, ale XPKatana

http://aminet.net/util/pack/XPKatana.lha

pakuje i rozpakowuje pliki bezproblemowo. Wychodzi wiec na to, ze natywne ZHXPK (i pewnie natywny YAM - tutaj nie wiem jak uruchomic XPK?) nie potrafi wspolpracowac biblioteka XPK w wersji 68k.

Odpowiedz

1 2 następna »

AmigaOS.pl