eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

środa, 17. lipca, 2019, 13:29

Amiga forum / AmigaOS 4.x / Kompatybilność starszych gier z AOS 4.1

Czytasz wątek: Kompatybilność starszych gier z AOS 4.1

Emu
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 11:47

Witam serdecznie,
czy ktoś mógłby łopatologicznie wyłożyć, jak to jest z kompatybilnością starszych gier z AOS 4.1 (chodzi głównie o tytuły z lat 1998-2001 wydane już na CD)? Naczytałem się sporo o emulacji, jakichś JIT-ach i Petunii i dalej nic nie wiem Da się (czy też nie da się) uruchomić poniższe tytuły:

- Myst
- Napalm
- Quake 1 i 2
- Heretic 2
- Payback
- Bubble Heroes
- Descent: Freespace The Great War
- Nightlong
- Foundation
- Wasted Dreams
- Hell Squad
- Exodus
- The 6th Sense Investigations
- Tales From Heaven
- Simon The Sorcerer 2
- The Feeble Files
- Earth 2140

Powyższe tytuły dotrą do mnie za jakiś czas, chciałbym wiedzieć co zostawić sobie a co rozdać po rodzinie

I jeszcze żeby nie zakładać nowego wątku, kilka wątpliwości:
- zadziała dowolny joystick na USB?
- gdzie można kupić jakieś gry kompatybilne z AOS 4.1?

Dziękuję serdecznie za sugestie,
Pozdrawiam
Emu




Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 12:41

@Emu
Witam serdecznie,
czy ktoś mógłby łopatologicznie wyłożyć, jak to jest z kompatybilnością starszych gier z AOS 4.1 (chodzi głównie o tytuły z lat 1998-2001 wydane już na CD)? Naczytałem się sporo o emulacji, jakichś JIT-ach i Petunii i dalej nic nie wiem Da się (czy też nie da się) uruchomić poniższe tytuły:

- Myst




Działa


@


- Napalm




Uruchamia się tylko do pewnego momentu, jednak grać nie można.


@

- Quake 1 i 2




Działają wersje natywne.



@

- Heretic 2




Działa



@

- Payback




Działa, ale bez dźwięku. W przypadku wersji dla Warp 3D, mogą dodatkowo występować przekłamania grafiki.



@

- Bubble Heroes




Nie wiem.



@

- Descent: Freespace The Great War




Działa wersja natywna.



@

- Nightlong




Tak.



@

- Foundation




Działa.



@

- Wasted Dreams
- Hell Squad




Niestety nie, ale obie gry działają dosyć ładnie pod E-UAE.



@

- Exodus




Działa.



@

- The 6th Sense Investigations




Nie wiem.



@

- Tales From Heaven




Niby działa, ale problemy są tak wielkie, że nie ma mowy o żadnym graniu.



@

- Simon The Sorcerer 2
- The Feeble Files




Działają, Można też w razie czego podeprzeć się SCUMMem.



@

- Earth 2140




Działa.


Generalnie w razie wątpliwości zawsze warto zajrzeć do naszego działu kompatybilność, który jest niestety zaniedbany i dotyczy stanu faktycznego dla finalnej wersji AmigaOS 4.0 (np. Wipeout działa, ale o zmianę tego nie mogę się doprosić Szamana chyba ze dwa lata), jednak w 90% nadal aktualny. Jeśli chodzi o strony zagraniczne, to najbardziej aktualne zestawienie oprogramowania względem kompatybilności znajdziesz na stronie BitterWolfa.


@


I jeszcze żeby nie zakładać nowego wątku, kilka wątpliwości:
- zadziała dowolny joystick na USB?
- gdzie można kupić jakieś gry kompatybilne z AOS 4.1?




Co do joyów i padów to wszystkie nie zadziałają, te które działają na pewno są wymienione w naszym dziale sprzęt.
Natomiast jeśli chodzi o gry, trzeba szukać po aukcjach, czy sklepach, takich jak Efunzine Vesalia czy Alinea Computer. Komercyjnego oprogramowania rozrywkowego przeznaczonego dla AmigaOS za wiele nie ma, na tę chwilę przychodzą mi do głowy tylko WordMeUp XXL i BOH, do kupienia na stronach autorów.



Odpowiedz

konrad
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 12:52

@mufa
np. Wipeout działa, ale o zmianę tego nie mogę się doprosić Szamana chyba ze dwa lata




Wyślij mi wszystkie zmiany, to poprawię.



Odpowiedz

Emu
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 17:27

Dziękuję bardzo za rozwianie wątpliwości. Oczywiście sprawdziłem podane linki wcześniej, chyba faktycznie można by co jakiś czas zaktualizować listę kompatybilności

Gdzie mógłbym znaleźć natywną wersję Descent: Freespace, to jest jakiś patch? Z tego co widzę w artykule na www to jest jakaś wersja od Hyperionu. Nie znalazłem jej na ich stronie, nawet po zalogowaniu.

Pozdrawiam i dziękuję

Emu

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 17:53

@Emu


Gdzie mógłbym znaleźć natywną wersję Descent: Freespace, to jest jakiś patch? Z tego co widzę w artykule na www to jest jakaś wersja od Hyperionu. Nie znalazłem jej na ich stronie, nawet po zalogowaniu.




Masz Descenta zarejstrowanego na stronie Hyperionu?

Odpowiedz

Emu
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 17:59

Nie, paczka jest w drodze. Ale rozumiem, że będę musiał zarejestrować i wtedy pojawi się update, tak? Coś jak z AOS 4 było?

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 19:35

@Emu
Nie, paczka jest w drodze. Ale rozumiem, że będę musiał zarejestrować i wtedy pojawi się update, tak? Coś jak z AOS 4 było?




Tak, mogą być jednak problemy z zarejestrowaniem starych gier (przynajmniej niedawno były), wtedy trzeba słać maila do Hyperionu.

Odpowiedz

Emu
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 19:53

Dziękuję bardzo za odpowiedzi.

Pozdrawiam
Emu

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-28 21:14

Jeszcze dodam że jak donosi Amig_OS, z rejestracją starych gier nie ma już problemów.

Odpowiedz

konrad
Nieaktywny użytkownik starego forum

Re:Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-10-29 16:52

Poprawiona lista kompatybilności najnowszego AmigaOS ze starym oprogramowaniem już na stronie:
http://www.amigaos.pl/kompatybilnosc.html

Odpowiedz

necavi
Nieaktywny użytkownik starego forum

Re:Kompatybilność starszych gier z AOS 4.1 wysłany: 2009-11-01 05:22

@konrad
Poprawiona lista kompatybilności najnowszego AmigaOS ze starym oprogramowaniem już na stronie:
http://www.amigaos.pl/kompatybilnosc.html




Listę można by uzupełnić o Disk Master, który ma wersje na OS4.
[url]http://www.intuitionbase.com/ossoftware.php?category=1&letter=d
[i]"A file manager, one of the first native applications."[/i]

Odpowiedz

alekc
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2010-03-14 16:19

@mufa
@Emu


- Exodus




Działa.





Próbuję właśnie uruchomić Exodusa na OS 4.1 U1. Po pierwsze program setup potrafi zawiesić cały system. Po drugie co wpisać jako device dla CD?

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2010-03-14 18:40

@alekc
@mufa
@Emu


- Exodus




Działa.





Próbuję właśnie uruchomić Exodusa na OS 4.1 U1. Po pierwsze program setup potrafi zawiesić cały system. Po drugie co wpisać jako device dla CD?




Uaktualnienie systemu nie wpłynęło negatywnie na działanie Exodusa, czyli uruchamia się tak jak przedtem. W czasie startu, czy też po wczytaniu się planszy tytułowej gra grimmuje ale nie ma co się tym przejmować tylko klikać na ignore errors. W czasie samej rozgrywki już problemów być nie powinno (nie licząc tego że gra działa zbyt szybko). Co do device, to podaj taki jaki jest odpowiedzialny za obsługę Twojego napędu, u mnie jest to sii0680ide.device unit 1.

P.S.

Swego czasu autorzy wypuścili trochę poprawek http://www.aksonsoft.republika.pl/Akson/Download.html ale ta z naszego punktu widzenia najistotniejsza, czyli ta która jak tam pisze umożliwia odpalenie gry na AmigaOS 4 (a tak naprawdę nie była z AmigaOS 4 testowana i była robiona bardziej po kątem MOSa) nie jest zalecana. Być może pamięć mnie zawodzi (od czasu wypuszczenia tych poprawek minęło już dobrych parę lat), ale coś mi się kojarzy że po zainstalowaniu tej łatki osiągamy skutek odwrotny do zamierzonego, czyli gra się nie uruchamia.

Odpowiedz

alekc
Nieaktywny użytkownik starego forum

Re:Kompatybilność starszych gier z AOS 4.1 wysłany: 2010-03-15 10:38

OK, posunąłem się do przodu - udaje mi się odpalić grę (po wymianie setup na 2.0) , ale nie znajduje animacji (odpalę snoopiego i sprawdzę) a potem wyświetla ekran z napisem Exodus i odczytuje z CD. Niestety robi to w nieskończoność. Płyta jest raczej ok bo jeszcze 2 tygodnie temu działała a installer nie zgłosił żadnych problemów. Czy trzeba konwertować grafiki na kartę graficzną (jeden z patchy oferuje taką opcję)? W jakiej rozdzielczości uruchamialiście Exodusa pod 4.x na kartach graficznych?

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Kompatybilność starszych gier z AOS 4.1 wysłany: 2010-03-15 17:41

Wydaje mi się że trzeba konwertować na kartę GFX, ale trudno mi się ze 100% pewnością wypowiadać o rzeczach którymi nie zajmowałem się od dobrych kilku lat.
Co do rozdziałek, to ja uruchamniałem w zalecanych, czyli 320x240 dla gry i 640x480 dla plansz. Oczywiście tryby o tak niskich rozdziałkach jak 320x256 trzeba sobie zmajstrować.

Odpowiedz

1 2 następna »

AmigaOS.pl