eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

wtorek, 16. lipca, 2019, 21:01

Amiga forum / AmigaOS 4.x / AmigaOS4 - pierwsze wrazenia

Czytasz wątek: AmigaOS4 - pierwsze wrazenia

respector
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-21 21:47

Słowo się rzekło, poniżej więc obiecana relacja z moich pierwszych "bojów" z nowym systemem. Opis mój ma charakter recenzji i jest skierowany zarówno do osób, które dopiero zastanawiają się nad zakupem systemu (celem ułatwienia im podjęcia decyzji), jak i do obecnych użytkowników (celem porównania wrażeń). Sporo w moim będzie porównań do MOS-a, które prosżę mi wybaczyć, ale - jak napisałem wcześniej - poza Amigą 4000 z CyberStorm PPC i systemem 3.9 byłem również wcześniej użytkownikiem MorphOSa, więc porównanie do tego systemu jest dla mnie zupełnie naturalne i często się wręcz samo narzuca.

Wprawdzie przesyłkę z Amigakit dostałem we wtorek, ale niestety nawał pracy i innych obowiązków zmusił mnie do odłożenia instalacji do czwartku, a dopiero teraz mam wreszcie trochę czasu, żeby coś więcej na ten temat napisać. Ale lepiej późno niż wcale.

Po rozerwaniu folii drżącymi rękami i otwarciu pudełka - pierwsze wrażenie: system jest bardzo porządnie wydany... można wręcz powiedzieć, że "w starym dobrym stylu". Dostałem kartonowe pudełko do samodzielnego złożenia, tłoczoną płytę instalacyjną z naklejonym na pudełku numerem seryjnym oraz dwie instrukcje, co prawda niezbyt wyczerpujące, ale za to wydrukowane w kolorze na ładnym kredowym papierze. Jedna z instrukcji zwie się "Installation Guide" i opisuje krok po kroku proces instalacji systemu omawiając pokrótce rozmaite parametry tejże instalacji. Druga broszurka to "Quickstart Guide", który w zamierzeniu autorów ma wprowadzić użytkownika w świat AmigaOS, przy czym ewidentnie opis kierowany jest to osób, które z AmigaOS nie miały do czynienia nigdy, lub też od bardzo długiego czasu. Bardzo przyjemny jest wstęp, ktrótka historia Amigi w pigułce (począwszy od HiToro i Jaya Minera, a skończywszy na czasach Hyperionu). Dalej jest bardzo pobieżny opis interfejsu, struktury katalogów systemowych, funkcjonalności samego systemu, omówienie kilku "flagowych" aplikacji oraz sterta linków internetowych. Szkoda, że jest to faktycznie "Quick" manual, przydałoby się coś znacznie grubszego, bo przecież jest o czym pisać...

Po przejrzeniu instrukcji zabrałem się za instalację nowego systemu operacyjnego. Na dysku w moim Pegasosie2, którego mam od 2004 roku był zainstalowany Morphos 1.4.5 oraz demo tego samego systemu w wersji 2.4. Specjalnie na potrzeby AmigaOS4 postanowiłem podłączyć jednak zupełnie nowy dysk i zainstalować system całkowicie "na czysto". I tutaj zaczęły się problemy... Użyłem dysku ata 40gb Quantum podłączonego do wbudowanego kontrolera IDE na płycie pegasosa. MediaToolbox pod instalatorem aos4 przy użyciu domyślnego sterownika peg2ide.device wykrył pięknie dysk, który następnie podzieliłem na partycje zgodnie z zawartymi w instrukcji zaleceniami ("boot loader" + kolejne partycje robocze + partycja swap). Dalej kopiowanie plików, wstępna konfiguracja etc. - po czym restart i... dupa! "Unable to load blablabla". Okazało się, że openfirmware Pegasosa za cholerę nie może znaleźć i załadować do pamięci pliku amigaboot.of. Tutaj mała dygresja - nie wiem, jak to się odbywa na AmigaONE czy SAM440, ale na Pegasosie ładowanie systemu operacyjnego wygląda tak, że OpenFirmware Pegasosa wczytuje plik bootujący z (zazwyczaj) pierwszej niedużej partycji "boot loader" i dopiero wtedy wczytywany jest właściwy system operacyjny (przy czym partycja "bootująca" dla samego systemu może być już zupełnie inna). Mimo kilku prób, czytania dokumentacji OpenFirmware itp. nie udało mi się tego problemu rozwiąząć. Spędziłem nad tym dobre 3 godziny i nic. Miałem już rozmaite pomysły... aż wreszcie z ciekawości odpaliłem instalatora MorphOS i kazałem mu instalować system na nowym dysku. Po restarcie - przy próbie ładowania morphosowego boot.img ten sam komunikat, co w przypadku amigowego amigaboot.of. Wtedy zrozumiałem, że przyczyną problemów nie jest Bogu ducha winny AmigaOS4, tylko open firmware Pegasosa, który po prostu nie potrafi z nieznanych mi powodów obsłużyć akurat tego dysku i załadować z niego boot file (chociaż z poziomu open firmware dysk jest widoczny, jak również można sobie wylistować zawartość partycji bootującej!). W tej sytuacji podłączyłem spowrotem stary dysk, odpaliłem po raz ostatni MorphOSa, zrobiłem backup danych i... format. Dalej instalator AOS4 i ponownie cała instalacja, która tym razem odbyła się już bez najmniejszych problemów. W tym miejscu chciałbym zaznaczyć szybkość kopiowania plików z tłoczonej płyty, która powoduje, że instalacja AmigaOS4 trwa *zdecydowanie* szybciej niż MorphOSa 2.4.

Po zakończeniu pracy instalatora nastąpił restart - i tutaj pierwsze pozytywne zaskoczenie. Otóż po załadowaniu systemu po "zimnym resecie", każdy kolejny "soft reset" (czyli ctrl-amiga-amiga) powoduje restart samego systemu operacyjnego, bez konieczności ponownego ładowania amigaboot.of, kickstartu, sterowników niskiego poziomu itp. Duże brawa za to rozwiązanie. Co prawda nie zawsze miękki restart jest możliwy w przypadku ordynarnej zwiechy, ale o ile tylko ctrl-amiga-amiga zadziała - system wstaje w ciągu dosłownie kilku sekund. Za pierwszym razem zrobiło to na mnie duże wrażenie.

OK - po rzeczonym pierwszym restarcie oczom moim ukazał się desktop workbencha, a po chwili requester w języku ojczystym (praktycznie cały system jest spolszczony) inforumujący mnie o pierwszym uruchomieniu nowego systemu. Następnie uruchomił się post-instalacyjny kreator konfiguracji, który poprowadził mnie "za rękę" przez wstępne ustawienie rozdzielczości ekranu (zgodnie z parametrami monitora podanymi podczas instalacji), konfigurację AHI oraz ustawienia sieci. Na tym etapie wszystko odbyło się bez żadnych problemów i w tym momencie rozpocząłem używanie nowego systemu.

Teraz przyszedł czas na "tuning" ustawień, instalację dodatkowych sterowników i dostowanie wszystkiego zgodnie ze swoimi preferencjami. Na pierwszy ogień poszedł monitor i ustawienia rozdzielczości ekranu... jako że instalator nie uwzględnia rozdzielczości wyższych niż 1280x1024, konieczne jest ręczne ustawienie żądanej rozdzielczości. Tutaj kolejne porównanie z MorphOSem, które tak na prawdę oddaje największą różnicę między tymi systemami. Rożnica ta to stopień "amigowości" versus nowe rozwiązania, odchodzące od amigowych standardów w imię wygody użytkownika i "nowych trendów". Otóż w nowym MorphOS, żeby zmienić parametry posiadanego monitora wystarczy odpalić sobie z menu ustawienia systemu (narzuca się porównanie z windowsowym control panelem), gdzie klikamy sobie na "Monitors" i wybieramy żądany przez nas tryb. Pod AmigaOS4 należy otworzyć DEVS:Monitors i wejść we właściwości danego sterownika dodająć we właściwościach ikonki żądane przez nas tryby. Jakież to amigowe i intuicyjne dla kogoś kto przyzywczajony jest do AmigaOS. Tak więc pod morphosem zmieniając swego czasu ustawienia systemu poczułem się trochę jak użytkownik windows, natomiast pod AmigaOS4 poczułem się jak na mojej Amidze 4000. Do tej kwestii wrócę jeszcze później.

Dla mojego monitora natywną rozdzielczością jest 1680x1050 i taką też rozdzielczość ustawiłem w Prefs:ScreenMode, ale... i tu znowu probem: obraz przesunięty był o jakieś 5 centymetrów w lewo. Niestety nie udało mi się znaleźć na ten temat nic w sieci, więc wróciłem do DEVS:Monitors i zacząłem kombinować z trybami wyświetlania obrazu... zmieniając wartość częstotliwości odświeżania uzyskiwałem najrozmaitsze efekty i w końcu dobrałem sobie taką wartość, przy której obraz wyświetlany jest prawidłowo. Pytanie dlaczego na standardowych 60Hz przy natywnej rozdzielczości obraz przesunięty jest w lewo pozostaje nadal bez odpowiedzi...

Kolejnym krokiem była instalacja sterownika bezprzewodowej karty sieciowej prism2.device. I tutaj pojawił sie kolejny - największy jak do tej pory (bo nierozwiązany!) problem. Otóż jakakolwiek próba załadowania sterownika powoduje zwiechę systemu "na dębowo". Karta jako taka działa prawidłowo, bo pod MorphOSem używałem jej z powodzeniem... więc problem jest niestety po stronie systemu (oczywiście używam sterownika w wersji dla AOS4, bo w archiwum są wersje dla MOS i AOS4). Z czymś się gryzie, tylko niestety nie mam pojęcia z czym. Probowałem wkładać ją do 3 różnych slotów PCI, zmieniałem kartę graficzną na inną... wszystko bez rezultatu. Poza aktualną wersją 1.7 sterownika prism2.device probowałem też starszej wersji 1.6, ale nie było żadnej różnicy... Może ktoś z Was spotkał się z podobnym problemem i udało mu się go jakoś rozwiązać..??? Dodam, że to dla mnie dość istotny problem, bo router mam w innym pokoju i w tej chwili muszę ciągnąć kabel przez całe mieszkanie (

Tak więc tymczasowo podłączyłem sieć przy pomocy ordynarnego druta i zacząłem korzystać z sieci. Pierwszym krokiem było oczywiście ściągnięcie i zainstalowania najnowszego OWB (3.19, które dziś zostało zastąpione przez 3.20). Przeglądarka działa zupełnie bezproblemowo, brakuje jej kilku przydatnych funkcji które posiada OWB w wersji na "konkurencyjny system" (np. menadżer pobierania plików), ale za to - co ważniejsze - działa chyba trochę stabilniej i zdecydowanie szybciej. Moje wrażenia są takie, że strony są renderowane szybciej, szybciej działa scrollowanie ekranu i ogólnie działa to jakoś sprawniej. W ogóle AOS4 działa szybciej od MOSa i moje subiektywne odczucia są takie, że jest "lżejszy" i jakby szybciej reaguje na myszkę Potwierdził to zresztą test P96Speed w zakresie operacji na oknach workbencha, gdzie AOS4 jest prawie czterokrotnie szybszy (testowałem na dokładnie tym samym sprzęcie, czyli mój Pegasos2 z kartą Radeon 9000 pro).

Kolejnym krokiem było zarejestrowanie się na stronie Hyperionu i ściągnięcie uaktualnień do systemu. Po instalacji QuickFix do systemu 4.1 zaobserwowałem poprawę stabilności systemu, szczególnie w przypadku uruchamiania programów napisanych dla AOS3. Skoro już przy stabilności jesteśmy, to po kilku dniach dość intensywnego używania AOS4 jestem pozytywnie zaskoczony jego stabilnością. Nie wiem jak ta sprawa wyglądała w przypadku systemu w wersji 4.0 (czytałem na ten temat rozmaite opinie i miałem w związku z tym trochę obaw), ale w 4.1 wygląda to dość dobrze. Z moich obserwacji wynika, że największy problem stanowią rzeczone wyżej programy pisane dla wersji 3.x systemu i procesorów 68k. Tutaj zaryzykowałbym stwierdzenie, że MOS radzi sobie trochę lepiej, ale ogólna stabilność systemu jest w obu przypadkach porównywalna. Piszę to z perspektywy zwykłego użytkownika, który korzysta z komputera do przeglądania internetu, oglądania filmów, słuchania muzyki, emulacji itp. (co się tyczy emulacji - DOSBox w wersji na AOS4 chodzi u mnie szybciej niż pod MOSem, zajętość procesora przy "CpuCycles" standardowo ustawionym na 3000 nie przekracza 40%).

Reasumując: po kilku dniach używania wydsaje mi się, że AOS4 spełnił moje oczekiwania i był to dobry wybów. Jest to zdecydowanie bardzie "amigowy" system, niż MOS. Zresztą na każdym kroku widać tą różnicę w filozofii twórców obydwu systemów... MOS "czerpie z filozofii AOS", ale ją modyfikuje w poszukiwaniu usprawnień i nowych rozwiązań. W tym poszukiwaniu odszedł już jednak od pierwowzoru dość daleko. Oczywiście wielu użytkownikom to nie przeszkadza i takie podejście im odpowiada ("trzeba iść z duchem czasów") i np. MOSowy Ambient jest faktycznie w swojej obecnej wersji szalenie wygodny, tym niemniej coś za coś - przez to MOS zatracił w dużym stopniu amigowy klimat. Owszem MOS to system lekki, szybki, dość wygodny i nadal w znacznym stopniu zgodny z AOS, ale - jeśli chodzi o wrażenie z użytkowania - niezbyt amigowy. Pod względem tego trudno definiowalnego amigowego "feelingu" AOS4 bije MOSa na głowę. Dla wielu to będzie bez znaczenia, ale dla mnie to jest ważne, bo właśnie dlatego nadal używam systemu Amigi, a nie np. Linuksa. Ja tego właśnie "feelingu" poszukiwałem, tego brakowało mi już coraz bardziej w kolejnych wersjach MOSa i myślę, że to znalazłem w nowym AmigaOS 4.1. Nie zagłębiając się w szczegóły techniczne (w rodzaju czy i dlaczego bilblioteka .so jest mniej amigowa od .library), tylko skupiając się na perspektywie *użytkownika* stwierdzam, że nowy AmigaOS jest systemem w 100% amigowym i godnym następcą AmigaOS 3.x na nowych platformach sprzętowych. Dlatego wszystkich, którzy jak ja - tęskniąc za Amigą coraz częściej wyłączali MOSa i odpalali wysłużoną A4000, ponieważ praca na niej sprawiała im po prostu większą przyjemność - zachęcam do kupna AmigaOS 4.1.

ufff... dziękuję za uwagę.

p.s. post popełniony na AmigaOS4.1 i OWB 3.20.



Odpowiedz

amigafan
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 00:11

@respector
Tutaj mała dygresja - nie wiem, jak to się odbywa na AmigaONE czy SAM440, ale na Pegasosie ładowanie systemu operacyjnego wygląda tak, że OpenFirmware Pegasosa wczytuje plik bootujący z (zazwyczaj) pierwszej niedużej partycji "boot loader" i dopiero wtedy wczytywany jest właściwy system operacyjny (przy czym partycja "bootująca" dla samego systemu może być już zupełnie inna).



Na AmigaOne wczytuje się najpierw Kickstart, który w postaci modułów jest w katalogu Kickstart na partycji systemowej. Nie trzeba tworzyć, rodem z linuxa, jakichś oddzielnych partycji z loaderem.
@respector
open firmware Pegasosa, który po prostu nie potrafi z nieznanych mi powodów obsłużyć akurat tego dysku i załadować z niego boot file (chociaż z poziomu open firmware dysk jest widoczny, jak również można sobie wylistować zawartość partycji bootującej!)



Po raz kolejny można przeczytać, że boski pegasos ma coś skopane w swoim IDE, podczas gdy ten rzekomo "zabugowany" kontroler IDE wbudowany w AmigaOne radzi sobie z różnymi dyskami bez problemu - podłączałem do niego kilka różnych dysków m.in. największe dyski IDE - Seagate 750GB i nigdy nie miałem z nimi żadnych problemów.
@respector
Otóż po załadowaniu systemu po "zimnym resecie", każdy kolejny "soft reset" (czyli ctrl-amiga-amiga) powoduje restart samego systemu operacyjnego, bez konieczności ponownego ładowania amigaboot.of, kickstartu, sterowników niskiego poziomu itp.



Normalna rzecz. W A1 Kickstart również nie jest ponownie ładowany po soft-reset. W MOSie tak nie ma ?!
@respector
obraz przesunięty był o jakieś 5 centymetrów w lewo



W LCD wystarczy nacisnąć "auto" aby obraz sam się wycentrował. Próbowałeś tak czy masz monitor kineskopowy? W kineskopowym musisz po prostu użyć ustawień monitora aby ręcznie wycentorać obraz.
@respector
Kolejnym krokiem była instalacja sterownika bezprzewodowej karty sieciowej prism2.device. I tutaj pojawił sie kolejny - największy jak do tej pory (bo nierozwiązany!) problem.



Opisz bliżej problem. Kiedy system się wiesza? Czy dobrze zainstalowałeś sterownik - prism2defaults musi być w odpowiednim miejscu sekwencji startowej. Czytałeś mój artykuł na temat wifi? http://www.exec.pl/artykuly/amiga_i_siec_wi-fi.jsp
@respector
W ogóle AOS4 działa szybciej od MOSa i moje subiektywne odczucia są takie, że jest "lżejszy" i jakby szybciej reaguje na myszkę Potwierdził to zresztą test P96Speed w zakresie operacji na oknach workbencha, gdzie AOS4 jest prawie czterokrotnie szybszy (testowałem na dokładnie tym samym sprzęcie, czyli mój Pegasos2 z kartą Radeon 9000 pro).



Ciszej! Takie stwierdzenia mogą zniszczyć mosistowską propagandę o szybkości MOSa. Tam nadal podniecają się liczbami słynnego francuskiego testu, gdzie np. porównywano szybkość USB2.0 pod MOSem z USB1.1 pod OS4
@respector
Jest to zdecydowanie bardzie "amigowy" system, niż MOS.



W końcu jest to AmigaOS

Odpowiedz

respector
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 01:13



@

Na AmigaOne wczytuje się najpierw Kickstart, który w postaci modułów jest w katalogu Kickstart na partycji systemowej. Nie trzeba tworzyć, rodem z linuxa, jakichś oddzielnych partycji z loaderem.



To kwestia architektury sprzetu, a nie systemu. To nie musi byc koniecznie odrebna partycja, wazne tylko zeby byla w przestrzeni bodajze pierwszych 100gb. Co nie zmienia faktu, ze plik boot loadera musi byc zaladowany (na szczescie w przypadku AOS4, dzieki temu sprytnemu resetowi - tylko raz).



@

Po raz kolejny można przeczytać, że boski pegasos ma coś skopane w swoim IDE, podczas gdy ten rzekomo "zabugowany" kontroler IDE wbudowany w AmigaOne radzi sobie z różnymi dyskami bez problemu - podłączałem do niego kilka różnych dysków m.in. największe dyski IDE - Seagate 750GB i nigdy nie miałem z nimi żadnych problemów.



Ja tez uzywalem rozmaitych dyskow i dotychczas nie mialem problemow. Wydaje mi sie, ze problem nie dotyczy samego kontrolera IDE, tylko open firmware. Problemy z dostepem do tej partycji mialem wylacznie z poziomu open firmware - jesli zabootowalem system z innego dysku (albo z CD) wszystko dzialalo ok i dysk/partcycje byly pieknie widoczne. Byc moze upgrade openfirmware rozwiazalby sprawe, ale wole sie do tego nie dotykac (po co kusic los...). Poki co zamowilem sobie kontroler sata na PCI (na chipsecie SIL3512) i zamierzam podlaczyc jakis nowszy dysk w ten sposob. Zobaczymy jakie beda transfery...




@
@respector
Otóż po załadowaniu systemu po "zimnym resecie", każdy kolejny "soft reset" (czyli ctrl-amiga-amiga) powoduje restart samego systemu operacyjnego, bez konieczności ponownego ładowania amigaboot.of, kickstartu, sterowników niskiego poziomu itp.



Normalna rzecz. W A1 Kickstart również nie jest ponownie ładowany po soft-reset. W MOSie tak nie ma ?!




Nie i wlasnie stad moje zaskoczenie.



@
W LCD wystarczy nacisnąć "auto" aby obraz sam się wycentrował. Próbowałeś tak czy masz monitor kineskopowy? W kineskopowym musisz po prostu użyć ustawień monitora aby ręcznie wycentorać obraz.



Mam LCD i oczywiscie probowalem automatycznie wycentrowac obraz na samym poczatku (i wlasnie tak mi sie centrowal - z kilkucenymetrowym przesunieciem). Anyway - problem juz rozwiazany.



@
Opisz bliżej problem. Kiedy system się wiesza? Czy dobrze zainstalowałeś sterownik - prism2defaults musi być w odpowiednim miejscu sekwencji startowej. Czytałeś mój artykuł na temat wifi? http://www.exec.pl/artykuly/amiga_i_siec_wi-fi.jsp



Obsluge prism2 znam, bo uzywalem tego z powodzeniem na MOSie i mysle ze dobrze zainstalowalem sterownik (zreszta co tam mozna zrobic zle...). Wiem, ze na AOS4 prism2defaults musi byc przed C:AddNetInterface, ale to niestety nie ma zadnego znaczenia, bo gdyby sterownik dzialal, to - co najwyzej - nie mialbym sieci, albo AddNetInterface czekalby na starcie dlugo na przyznanie adresu z dhcp. Ale w moim przypadku system po prostu umiera w momencie proby otwarcia prism2.device i to niezaleznie od uzywanego stosu tcp/ip. Jak wylacze domyslny stos AOS4, wyrzuce AddNetInterface i np. sprobuje otworzyc prism2.device genesisem, czy Miami to jest dokladnie ten sam efekt, czyli natychmiastowa zwiecha. Dlatego wlasnie podejrzewam raczej jakis konflikt...



@
@respector
W ogóle AOS4 działa szybciej od MOSa i moje subiektywne odczucia są takie, że jest "lżejszy" i jakby szybciej reaguje na myszkę Potwierdził to zresztą test P96Speed w zakresie operacji na oknach workbencha, gdzie AOS4 jest prawie czterokrotnie szybszy (testowałem na dokładnie tym samym sprzęcie, czyli mój Pegasos2 z kartą Radeon 9000 pro).



Ciszej! Takie stwierdzenia mogą zniszczyć mosistowską propagandę o szybkości MOSa. Tam nadal podniecają się liczbami słynnego francuskiego testu, gdzie np. porównywano szybkość USB2.0 pod MOSem z USB1.1 pod OS4




Nawet jesli uznamy wynik testu S96Speed za srednio wiarygodny to i tak moje subiektywne odczucia sa takie, ze AOS4 dziala szybciej (i to z wlaczonymi wszystkimi efektami przezroczystosci itp.). Mam oczywiscie na mysli 2D, bo 3D na razie nie testowalem w zaden sposob (w gry sie raczej nie bawie).




Odpowiedz

Drako
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 11:30



@
Specjalnie na potrzeby AmigaOS4 postanowiłem podłączyć jednak zupełnie nowy dysk i zainstalować system całkowicie "na czysto". Po restarcie - przy próbie ładowania morphosowego boot.img ten sam komunikat, co w przypadku amigowego amigaboot.of. Wtedy zrozumiałem, że przyczyną problemów nie jest Bogu ducha winny AmigaOS4, tylko open firmware Pegasosa, który po prostu nie potrafi z nieznanych mi powodów obsłużyć akurat tego dysku i załadować z niego boot file (chociaż z poziomu open firmware dysk jest widoczny, jak również można sobie wylistować zawartość partycji bootującej!).



Problem z odczytem dysku z poziomu OpenFirmware'u wynika prawdopodobnie z tego że nie skasowane zostało MBR .
Które domyślnie jest na każdym nowym dysku


Odpowiedz

amigafan
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 13:39

Niektorzy na sąsiednim portalu ośmieszają się wygłaszając nieprawdziwe opinie pisząc o czymś o czym nie mają żadnego pojęcia.
Więc w kwestii wyjaśnienia:
Ustawianie trybów monitora w tooltypach NIE jest cechą P96 .
W P96 pod AOS3.x takie rzeczy ustawiało się poprzez P96mode. Program był wygodny ale może niezbyt intuicyjny dla początkującego - ale i tak o lata świetlne bardziej wygodny i intuicyjny niż jego odpowiednik CGXmode. Po przesiadce z PicassoIV (pod p96) na CVPPC (gdzie sterowniki są tylko pod CGX) po prostu nie mogłem znieść tego ... CGXmode

Ustawienia poprzez tooltypes zostały wprowadzone w 4 uaktualnieniu OS4 pre-release, jako rozwinięcie systemu a zarazem P96, które stało się jego częścią.
Oczywiście było to dokładnie dawno temu opisane w artykułach na tym portalu.
Odnoszę nieodparte wrażenie, że osoby najbardziej jeżdżące po OS4 jak i eXecu nigdy nie zadały sobie trudu aby nie tylko używać tego systemu ale nawet przeczytać kilka artykułów na jego temat.
Zamknęli się w świecie mosistowskiej propagandy, dostosowując "fakty" do swoich potrzeb. Stąd potem można przeczytać banialuki w stylu "tryby w ikonkach monitora są typowe dla Picasso96"

Odpowiedz

respector
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 13:51




@
Problem z odczytem dysku z poziomu OpenFirmware'u wynika prawdopodobnie z tego że nie skasowane zostało MBR .
Które domyślnie jest na każdym nowym dysku




Dzieki, ale to nie raczej nie to. Odpisalem juz na ppa, (gdzie zostalem troche "wywolany do tablicy"), ze MBR kasowalem.


Odpowiedz

pawelini
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 14:32

Ten programik w os 4.x do ustawiania trybow to chyba najgorszy gniot programistyczny jaki widzialem, powinni to wywalic i zamiast niego dac readme jak ustawiac tooltypy. Bedzie to o wiele bardziej intuicyjne.

Z tym automode w monitorze lcd to najczystsza prawda Wpierw musialy poleciec wulgaryzmy i godzina prob ustawiania czegokolwiek poprzez screenmode, gdzie uzytkownik gdy juz wpadnie jak ten szit sie obsluguje, sam nie wie czy dziala dobrze czy zle, bym wpadl na to ze wystarczy nacisnac auto na monitorze lcd ;P

PS
Amigafan, jak otwierasz lodowke tez widzisz mosa ? :>

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 14:31

@respector

Teraz przyszedł czas na "tuning" ustawień, instalację dodatkowych sterowników i dostowanie wszystkiego zgodnie ze swoimi preferencjami. Na pierwszy ogień poszedł monitor i ustawienia rozdzielczości ekranu... jako że instalator nie uwzględnia rozdzielczości wyższych niż 1280x1024, konieczne jest ręczne ustawienie żądanej rozdzielczości. Tutaj kolejne porównanie z MorphOSem, które tak na prawdę oddaje największą różnicę między tymi systemami. Rożnica ta to stopień "amigowości" versus nowe rozwiązania, odchodzące od amigowych standardów w imię wygody użytkownika i "nowych trendów". Otóż w nowym MorphOS, żeby zmienić parametry posiadanego monitora wystarczy odpalić sobie z menu ustawienia systemu (narzuca się porównanie z windowsowym control panelem), gdzie klikamy sobie na "Monitors" i wybieramy żądany przez nas tryb. Pod AmigaOS4 należy otworzyć DEVS:Monitors i wejść we właściwości danego sterownika dodająć we właściwościach ikonki żądane przez nas tryby. Jakież to amigowe i intuicyjne dla kogoś kto przyzywczajony jest do AmigaOS. Tak więc pod morphosem zmieniając swego czasu ustawienia systemu poczułem się trochę jak użytkownik windows, natomiast pod AmigaOS4 poczułem się jak na mojej Amidze 4000. Do tej kwestii wrócę jeszcze później.

Dla mojego monitora natywną rozdzielczością jest 1680x1050 i taką też rozdzielczość ustawiłem w Prefs:ScreenMode, ale... i tu znowu probem: obraz przesunięty był o jakieś 5 centymetrów w lewo.




Ja też gustuję w starej szkole i nawet uproszczone rozwiązania z regulacją tooltypów ikony monitora jakoś mnie nie kręcą. Polecam stare dobre P96Mode, które nadal jest częścią systemu, może jest z tym trochę dłubaniny, ale przynajmniej każdy tryb można sobie wypieścić.


@


p.s. post popełniony na AmigaOS4.1 i OWB 3.20.





Dzięki za recenzję, fajnie się czytało.

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 14:35

@pawelini
Ten programik w os 4.x do ustawiania trybow to chyba najgorszy gniot programistyczny jaki widzialem, powinni to wywalic i zamiast niego dac readme jak ustawiac tooltypy. Bedzie to o wiele bardziej intuicyjne.




No i proszę, przed chwilą chwaliłem a jak widać są i zupełnie inne opinie. Cóż gusta bywają różne, ja tam mam nadzieję że P96Mode nie zostanie usunięty nigdy.

Odpowiedz

AmiZaP
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 14:57

Bardzo ciekawy opis pierwszych wrażeń. Mam nadzieję, że nie wywoła on jakiejś wielkiej zawieruchy, tylko da wszystkim do myślenia.
Szczególne wrażenie zrobiło na mnie porównanie użytkowe dotyczące look&feel AmigaOS 4 w porównaniu z MorphOS'em.

Do tej pory zastanawialiśmy się i polemizowaliśmy tu i ówdzie z kolegami z niebieskiej strony, co jest istotą amigowego look&feel.
Były takie głosy, że chodzi o jakość pracy z pulpitem systemowym i pojawiały się twierdzenia np. o wyższyści Ambienta nad Workbenchem.
Nie do końca mnie to przekonywało bo przecież tak naprawdę nawet i pod kontrolą AmigaOS 3.x ludzie używali wielu różnych zamienników
Workbencha i nie twierdzili przecież, że amigowy feeling w jakiś istotny sposób się zmieniał. Tak więc ta argumentacja na zdrowy rozum
odpadała.

Musiało chodzić o coś jeszcze i dziękuję autorowi wątku za podpowiedź. Ja nie mam możliwości by porównywać na bieżąco MOS'a
i AmigaOS 4, ale zawsze mi się wydawało, że chodzi o ogólną szybkość systemu. Respector potwierdził moje przypuszczenia:
AmigaOS 4 jest szybszy pod myszką, a więc chodzi o jego czas reakcji. To jest zasadnicze kryterium decydujące o amigowym look&feel,
oczywiście przy założeniu, że pozostałe aspekty: możliwość uruchamiania amigowego oprogramowania (a więc i API) istnieje.

Świetnie się stało, że Hyperion zachował ten najważniejszy aspekt działania systemu. Wierzyłem, że im się to uda i swoim produktem
podniosą tak wysoko poprzeczkę jakości, że konkurentom trudno będzie sprostać. Są klasą sami dla siebie.


Odpowiedz

konrad
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 14:58

@mufa
ja tam mam nadzieję że P96Mode nie zostanie usunięty nigdy.




Od następnej aktualizacji już go raczej nie będzie w systemie. Ustawienia trybów będzie można dokonać w programie ScreenMode. Będzie opcja ręcznego ustawienia lub system odczyta niezbędne parametry poprzez Display Data Channel z monitora i ustawi co potrzeba.

Odpowiedz

amigafan
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 16:17

@pawelini
godzina prob ustawiania czegokolwiek poprzez screenmode, gdzie uzytkownik gdy juz wpadnie jak ten szit sie obsluguje, sam nie wie czy dziala dobrze czy zle



A czego nie rozumiesz w preferencjach "screenmode" ?! Wybierasz tryb i tyle. W obecnej wersji tam przecież nie ma nic do kombinowania.
Jeżeli natomiast odnosisz się do P96mode to ciesz się, że nie byłeś zmuszony używać odpowiednika z CGX - chyba nazywa się modeedit.
Tam to dopiero byś się namęczył musząc ustawiać dla każdej rozdzielczości takie abstrakcyjne wartości (których próżno szukać w opisach technicznych posiadanego monitora) jak:
Sync lenght, Pulse offset, Pulse Lenght, Polarity, itd. Wtedy dopiero jest problem z wycentrowaniem obrazu.
@pawelini
jak otwierasz lodowke tez widzisz mosa



Na twoje tanie zaczepki i próby wywołania "flejma" nie będę odpowiadał.

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

Re:AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 19:05

@konrad


Od następnej aktualizacji już go raczej nie będzie w systemie. Ustawienia trybów będzie można dokonać w programie ScreenMode. Będzie opcja ręcznego ustawienia lub system odczyta niezbędne parametry poprzez Display Data Channel z monitora i ustawi co potrzeba.




W takim razie przegram go z ze starego systemu bo to świetne narzędzie np. samo AMD/ATI podaje że minimalną rozdzielczością dla Radeonów jest 640x480, ja bez problemu dzięki P96Mode uzyskiwałem 320x256 czy inne dziwaczne rozdziałki przydatne choćby do emulatorów odpalanych na pełnym ekranie. Nie wiem czy na podobną ekstrawagancję pozwalają aktualnie lansowane rozwiązania.

Odpowiedz

mufa
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-22 20:05

@AmiZaP
Bardzo ciekawy opis pierwszych wrażeń. Mam nadzieję, że nie wywoła on jakiejś wielkiej zawieruchy, tylko da wszystkim do myślenia.
Szczególne wrażenie zrobiło na mnie porównanie użytkowe dotyczące look&feel AmigaOS 4 w porównaniu z MorphOS'em.




AmigaOS 4, wygląda jak każdy AmigaOS i pracuje się na nim jak na starych AmigaOS tyle że wygodniej. MOS wiadomo, to że przez niezaznajomych z tematem bardzo często mylony jest z linuksem mówi samo za siebie. Znamienne dla mnie były wydarzenia na exec Party 2, Stefkos powiedział mi że on już nie za bardzo umiałby poruszać się w środowisku AmigaOS, jak to określał "za dużo klikania". Z kolei ja gdy podeszłem na chwilę do Pegasosa aby zobaczyć mosowe OWB, pogubiłem się w tym dziwacznym GUI całkowicie. Pamiętam że Stefkos musiał mi sam otwierać nowe zakładki, bo ja przez dłuższy czas kombinowałem gdzie się to robi... ) Słowem MOS odszedł już cholernie daleko od amigowego look&feel, choć rozumiem że userzy MOSa, którzy przez lata stopniowo przyjmowali coraz bardziej odchodzące od "amigowości" zmiany, nawet nie zdawają sobie z tego sprawy. Jednak dla kogoś kto podchodzi do tego systemu po raz pierwszy (a w moim przypadku można niemalże tak powiedzieć, gdyś ostatnio siedziałem przy MOSie na Toronto Meeting 2003), jest wręcz szokujące że ktoś może nazywać takie coś systemem amigowym.

Odpowiedz

AmiZaP
Nieaktywny użytkownik starego forum

AmigaOS4 - pierwsze wrazenia wysłany: 2009-11-23 15:30

Jak już pisałem wcześniej, nie jestem za tym by za kryterium feelingu amigowego brać klikologię.
Ona już się różniła dość mocno w MUI, Reaction, Intuition, pOS'ie itp. Każda z tych warstw narzucała swoją filozofię pracy z okienkami i ich elementami. Nie to decydowało o poziomie amigowatości tylko czas reakcji systemu. Można by użyć angielskiego terminu responsiveness.
O ile ta cecha była zachowana to ludzie akceptowali narzucony filozofią okienkową styl nawigacji.
Na marginesie tu już po raz pierwszy się okazało, że opóźnienia czasowe narzucone przez MUI (jego ciężar) irytowały sporą część światka amigowego.

Jeśli mielibyśmy ocenę feelingu sprowadzać tylko do klikologii to dojdziemy w agumentacji do takich absurdów jak:
twierdzenia o wyższości MOS'a nad AmigaOS 4.x dlatego, że jest połączeniem jakiejś części amigowego feelingu (klikologii) i postępu wyrażającego się takimi, a nie innymi zmianami tejże klikologii.
Po pierwsze, ciekawe jak wyliczają procent amigowatości w takim połączeniu?
Po drugie, taka a nie inna klikologia jest tylko rzeczą gustu.

Ja na przykład dalej pracuję na dwupanelowcach, przy czym bym nie siedział.
Ot, przyzwyczajenie takie.

Odpowiedz

1 2 następna »

AmigaOS.pl