eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

sobota, 24. sierpnia, 2019, 03:15

Dodano: 2011-06-27 11:56, Autor: rch, Kategoria: Oprogramowanie, Liczba wyświetleń: 2097

A A A

Gnumeric 1.8.4

Edgar Schwan zaktualizował najbardziej zaawansowany arkusz kalkulacyjny dostępny dla Amigi - Gnumeric, do wersji 1.8.4. Szczegóły zmian w stosunku do poprzedniej odsłony dostępnej dla naszej platformy (1.6.3) znajdziemy w dokumentacji zamieszczonej w archiwum z programem.


Dodaj komentarz

Piotr Ogrodowski
Czytelnik

komentarz #1 wysłany: 2011-06-27 21:33

Dla jasności warto byłoby dodać, że do uruchomienia potrzebny jest AmiCygnix. Jednak co jakiś czas pojawia się tu nowa, zupełnie zielona osoba zainteresowana nową Amigą (sam, pegasos, aone itd) i niekoniecznie może o takich rzeczach wiedzieć. Kiedyś bowiem było o wiele łatwiej - jak program był na AmigaOS3.1 to wiadomo było, że pod tą wersją systemu będzie działał. Jednak nie każdy zagląda na ppa.pl.

Odpowiedz

Konrad Bielski
Redaktor

komentarz #2 wysłany: 2011-06-27 22:01 w odpowiedzi na komentarz #1

Wymagania są podane w umieszczonym przy newsie linku.

Kiedyś bowiem było o wiele łatwiej - jak program był na AmigaOS3.1 to wiadomo było, że pod tą wersją systemu będzie działał.

Głupoty pleciesz. Programy pod AmigaOS 3.1 tak samo jak programy pod AmigaOS 4.1 mają swoje wymagania. Dość często oprócz samego programu trzeba doinstalować zewnętrzne elementy, które nie są dostarczane z systemem. Akurat w przypadku AmigaOS 4.1 królują programy tworzone w systemowym ReAction. Za czasów AmigaOS 3.1 to dopiero było instalowania: MUI, BGUI, ClassAct, Reaction, Triton, GadToolBox i inne cuda wianki.

Odpowiedz

Radov
Redaktor

komentarz #3 wysłany: 2011-06-27 22:03 w odpowiedzi na komentarz #1

Czy przy newsach o grach 3D mamy każdorazowo pisać, że wymaga MiniGL ze względu na mniej zorientowanych użytkowników?...

PS. GnuMeric ma jasno wyszczególnione wymagania software'owe.
PS2. Jesteś pewien, że jak kiedyś program był na AmigaOS 3.1 - to w żadnym przypadku nie trzeba było doinstalowywać dodatkowego oprogramowania żeby działał?

Odpowiedz

Piotr Ogrodowski
Czytelnik

komentarz #4 wysłany: 2011-06-27 22:48 w odpowiedzi na komentarz #3

Czy przy newsach o grach 3D mamy każdorazowo pisać, że wymaga MiniGL ze względu na mniej zorientowanych użytkowników?...

Po co się powstrzymywałeś, mogłeś od razu z grubej rury wystrzelić i napisać, że wymagany jest monitor i kabelek. Twój argument byłby jeszcze mocniejszy...

PS2. Jesteś pewien, że jak kiedyś program był na AmigaOS 3.1 - to w żadnym przypadku nie trzeba było doinstalowywać dodatkowego oprogramowania żeby działał?

Właśnie dlatego napisałem - powinno być to wspomniane w newsie. Czy tak trudno to pojąć? To może dokładniej: jeśli ktoś pisze, że program wymaga AmigaOS 3.1 i MUI to nikt nie będzie miał pretensji, że nie działa na "gołym AmigaOS 3.1). Teraz rozumiesz?

Odpowiedz

Radov
Redaktor

komentarz #5 wysłany: 2011-06-27 23:46 w odpowiedzi na komentarz #4

Po co się powstrzymywałeś, mogłeś od razu z grubej rury wystrzelić i napisać, że wymagany jest monitor i kabelek. Twój argument byłby jeszcze mocniejszy...
1. Gdzie ty tam widzisz jakiś argument? To tylko zwykła ironia.
2. Mogłem, ale wtedy relacja, którą wskazywałem ironią nie byłaby adekwatna.

To może dokładniej: jeśli ktoś pisze, że program wymaga AmigaOS 3.1 i MUI to nikt nie będzie miał pretensji, że nie działa na "gołym AmigaOS 3.1). Teraz rozumiesz?
A popatrz - w poprzedniej wiadomości napisałeś coś ZUPEŁNIE innego:
Kiedyś bowiem było o wiele łatwiej - jak program był na AmigaOS3.1 to wiadomo było, że pod tą wersją systemu będzie działał.
Jasno sugerowałeś, że kiedyś nie trzeba było pisać, że oprócz AmigaOS 3.1 jest wymagane coś więcej - bo jak zgaduję - ta jedna informacja implikowała zgodność z systemem.

Wróćmy jednak do meritum - dlaczego ktoś miałby mieć pretensje, że Gnumeric nie działa na gołym systemie?
- Wymagania Gnumerica są czytelnie opisane w jego dokumentacji.
- Informacja ta jest bardzo łatwo dostępna.
- Ściągnięcie i instalacja pakietu jest równie prosta.
Czasy, że mogłeś nabyć na giełdzie program bez potrzebnych bibliotek już dawno minęły.

Ponowię pytanie: w jakie detale wg Ciebie mamy się wdawać, żebyś był usatysfakcjonowany? Serwer X11 jest dla mnie tak samo podstawową rzeczą jak posiadanie aktualnej wersji biblioteki minigl, pythona, sterowników. Wszystkie te rzeczy są opisane w dokumentacji instalacyjnej. Jaką jej część mamy przepisywać do newsów? Czy takie przepisywanie ma sens?

Moim zdaniem nie. A zupełnie śmieszne byłoby pisanie w każdym newsie:
**UWAGA** ten program nie zadziała na gołym systemie. Trzeba doinstalować dodatkowe rzeczy!!!!"

Teraz rozumiesz?

Odpowiedz

Tomek Jaremczak
Czytelnik

komentarz #6 wysłany: 2011-06-27 23:56 w odpowiedzi na komentarz #4

Szacunek dla Piotra. 100 proc. racji!

Odpowiedz

Piotr Ogrodowski
Czytelnik

komentarz #7 wysłany: 2011-06-28 09:37 w odpowiedzi na komentarz #5

<bPonowię pytanie: w jakie detale wg Ciebie mamy się wdawać, żebyś był usatysfakcjonowany?

Może odpowiem w ten sposób. Czy można napisać dla systemu AmigaOS4.X program typu Gnumeric bez wspomagania sie AmiCygnix? Oczywiście, że można. Nie uważasz, że treść omawianego newsa bardziej pasowałaby do takiego programu? Jednak w przypadku Gnumeric tak nie jest, potrzebny jest AmiCygnix i warto o tym dla jasności wspomnieć. Inaczej by sprawa wyglądała, gdyby AmiCygnix stał się w AmigaOS4 standardem i wszystkie pojawiające się programy byłyby pod to pisane.

Odpowiedz

Konrad Bielski
Redaktor

komentarz #8 wysłany: 2011-06-28 10:51 w odpowiedzi na komentarz #7

Jednak w przypadku Gnumeric tak nie jest, potrzebny jest AmiCygnix i warto o tym dla jasności wspomnieć.

Przekonaj mnie, że warto. Na przykład opisz jakie miałeś problemy podczas instalacji Gnumerica i w którym miejscu przeszkadzał Ci brak takiej informacji.

Odpowiedz

SZAMAN
Redaktor

komentarz #9 wysłany: 2011-06-28 13:53 w odpowiedzi na komentarz #7

Właśnie zainstalowałem sobie nową wersje Nokia Ovi Suite pod XP. Fajna aplikacja (zaciągam nią darmowe mapy do mojej komórki), ale jakaś taka inna, niż pozostałe pod XP. Okazuje się, że ustrojstwo korzysta z Javy. Jave jednak mam w XP od zawsze, aktualizuje ją co jakiś czas i tyle. Wszystko dokładnie tak samo jak z Gnumeric pod AmigaOS. AmiCygnixa po prostu warto mieć, tak samo jak Javę pod XP. Trafne porównanie?

Odpowiedz

Piotr Ogrodowski
Czytelnik

komentarz #10 wysłany: 2011-06-28 13:54 w odpowiedzi na komentarz #8

Nie moja rola jest przekonywanie kogokolwiek. Moze news w ogole powinien byc jeszcze oszczedniejszy w slowa i wygladac np tak: "Gnumeric 1.8.4 ukonczony". I tyle. Po co pisac cokolwiek wiecej, przeciez kazdy wie, ze reszte informacji znajdzie w dokumentacji.

Odpowiedz

Konrad Bielski
Redaktor

komentarz #11 wysłany: 2011-06-28 14:21 w odpowiedzi na komentarz #10

Zachęcam do współpracy i do wysyłania bardzo obszernych i szczegółowych newsów. Jak widzisz news składa się z dwóch części: wstępu i rozwinięcia. Do tej drugiej części można napisać naprawdę dużo tekstu.

Odpowiedz

Mufa
konto zablokowane
lub usunięte

Czytelnik

komentarz #12 wysłany: 2011-06-29 09:01 w odpowiedzi na komentarz #10

Moze news w ogole powinien byc jeszcze oszczedniejszy w slowa i wygladac np tak: "Gnumeric 1.8.4 ukonczony". I tyle. Po co pisac cokolwiek wiecej, przeciez kazdy wie, ze reszte informacji znajdzie w dokumentacji.

Być może w ogóle nie powinno go być? Wiesz zawsze jest jakaś alternatywa. Akurat w tym przypadku były 3 newsy z rzędu do napisania, obiecałem rodzinie wyjazd nad jezioro, wiedziałem że Konrad również wyjechał na kilka dni a pozostala część redakcji ostatnio mało aktywna w tym temacie. Napisałem więc takie newsy na które akurat miałem czas, uznając że lepsza taka informacja niż jej całkowity brak i zarzuty iż na eXecu nic się nie dzieje. Niestety to tylko hobby za które nikt nam nie płaci. Dlatego też niekiedy trafiają się dłuższe newsy okraszone obrazkami czy filmikami, a niekiedy newsy pisane są w telegraficznym skrócie. Jak już pisał Konrad, każdy czytelnik może to zmienić i samemu zaangażować się w pisanie wiadomości.

Jeszcze co do samego Gnumerica, przecież nie jest to jakieś tam 54 GUI dla LHA tylko program o któym każdy interesujący się Amigą człowiek powinien słyszeć (wiadomo jaka jest u nas pustynia w temacie office). Jasne jest że gdy taki program pojawił się na Amigę po raz pierwszy wspominaliśmy w jakim środowisku pracuje. Natomiast teraz ten stan po prostu trwa. Jeśli kiedyś, tak jak np. w przypadku QT, Gnumeric nie będzie już potrzebował do działania AmiCygnixa, z pewnością o tym poinformujemy.

Odpowiedz

AmigaOS.pl

Polecamy
Najpopularniejsze
eXec blog

Świat poza Amigą: