eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

poniedziałek, 25. września, 2017, 08:22

Amiga forum / Inne / Potrzebne testy programu

Czytasz wątek: Potrzebne testy programu

r-tea
Czytelnik

Potrzebne testy programu wysłany: 2017-04-07 00:44

Witajcie.
Potrzebuje waszej pomocy w znalezieniu przyczyny, dlaczego mój program dla AmigaOS 3.x m68k wywala się na AmigaOS4.
Na wspomnianym już AmigaOS 3.x w pełni działa, na MorphOS działa, a na AmigaOS 4.x uruchamia się, ale wywala przy pierwszysm ruszeniu sliderów.
Potrzebuję też wiedzieć (bez ruszania sliderów), czy przyciski "CtC" też powodują crash.
Hexaco

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-07 12:46

@r-tea

Obczaję przez weekend - jest tam jakaś wersja z natywną binarką dla OS4? I czy jest jakiś tryb debug z logami?

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-07 19:53

@SZAMAN

Nieststy, takich rzeczy nie potrafię robić. Binarka jest dla AmigaOS 3.x m68k. Mam raport, że crash jest przy pierwszym ruszeniu sliderów, a ja chciałbym wiedzieć, czy program wywali się również przy naciśnięciu jednego z przycisków "CtC" (oczywiście bez wcześniejszego ruszania sliderów).

Odpowiedz

swinkamor12
Marian Nowicki Autor tego komentarza otrzymał żółtą kartkę
Czytelnik Katowice

Re: Potrzebne testy programu wysłany: 2017-04-08 07:49

@r-tea

Może jest ogólnie problem z językiem E i hookami.
Ja bym zaczął od przejścia na C i bibliotekę SDI do hooków.

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-09 16:37

@r-tea

Uruchomiłem program i tutaj masz crash loga z AmigaOS 4 po ruszeniu sliderów. Jest to błąd typu DSI i można kontynuować działanie programu - po tej czynności aplikacja normalnie działa, ustawiają się ładnie kolory, można używając przycisków CtC kopiować potrzebne nam wartości do schowka.

Nie wiem czy program także posiada taką funkcjonalność, ale zanim ruszyłem suwakiem i zignorowałem ten błąd próbowałem z palca wpisać jakąś wartość koloru, niestety wtedy nic się nie działo. No, ale nie wiem, czy coś takiego masz oprogramowane, czy po prostu jest to aplikacja, która ma działać tylko w jedną stronę: suwaki RGB -> wartości w tych polach do skopiowania. Najważniejsze jednak info - program nie wywala się gdy od razu użyjemy CtC, przed sliderami.

Swoją drogą przydatna apka, ale jeszcze lepsza byłaby opcja, która pozwalałaby na wskazywanie dowolnego kolory na ekranie, taki "picker", czy jak się to nazywa. Wtedy z projektu graficznego np. strony WWW mogę sobie pobierać kolorki i zapisywać je do CSSów.

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-09 22:22

@SZAMAN

Dziękuję. Bardzo rzetelnie opisałeś swoje testy i spostrzeżenia.
Ręczne wpisywanie wartości w polach string rzeczywiście nie ma wpływu na działanie programu. Takie jest moje założenie. Opisałem to w readme. Pola te są edytowalne tylko po to, gdyby znaleźli się tradycjonaliści, chcący kopiować do Clipboardu poprzez RAmiga+C zamiast klikać "CtC". Być może zbyt daleko z tym zaszedłem, i lepiej jakbym jednak zastosował zwykły Text zamiast String, lub ewentualnie oprogramować działanie programu w drugą stronę.
A 'picker' na dzień dzisiejszy raczej przewyższa moją powierzchowną wiedzę - ale pomarzyć można

A teraz zapodaję wersję, na której sprawdzeniu bardzo mi zależy:
Hexaco (EC)
Skompilowane natywnym EC m68k. Aby to zrobić musiałem niestety usunąć część zdrowego kodu z klasą Lamp.mcc, gdyż ten kompilator jej nie trawił, ale na ten moment ważniejszy jest test całości po kompilacji właśnie tym kompilatorem.
Zmień Szymon, proszę nazwę, podmień plik, i sprawdź jeszcze raz.
Z góry dziękuję.

Btw, mam już pierwszy raport od kogoś z OS4.1 że ta wersja działa bez żadnych niespodzianek !!!!!!!!!!!!!!!!!!! Yeah! :-D

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-10 20:19

@r-tea

Potwierdzam - ta nowe wersja "bez lampek" śmiga jak należy. Czekam na info o wydaniu programu i wrzucam newsa.

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-12 23:59

Jednak u paru zagranicznych userów OS4 ciągle coś "wychodzi". Gdy to opanuję, na pewno dam znać

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-14 20:53

Wersja po poprawkach sugerowanych na liście mailingowej AmigaE:
Hexaco po poprawkach
Potestujecie, proszę, jeszcze raz i dajcie znać. Jakieś graby okienka Hexaco mile widziane.

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-24 02:06

Wersja, która nie powinna już robić niespodzianek na OS4.x.
Dodatkowo wyposażona w możliwość konfiguracji przez ToolType-y w ikonce Coś, co mega lubię w AmigaOS
Bardzo proszę o testy i chciałbym jakieś graby okienka z OS4, aby dołączyć do oficjalnego archiwum.
Hexaco 0.9.5

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-24 10:06

@r-tea

Wieczorem postaram się przetestować i wrzucić tutaj obrazki.

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-24 20:08

@r-tea

Oto obrazki: Hexaco 1 i Hexaco 2.

Odpowiedz

r-tea
Czytelnik

Re: Potrzebne testy programu wysłany: 2017-04-25 13:58

@SZAMAN

dzięki.
Wszystko działa? Kopiowanie do clipboardu? Sprawdzałeś działanie tooltypów? Czy po ikonifikacji używa własnej ikonki?
Te rzeczy chciałbym na 100% wiedzieć z OS4.

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-25 14:01

@r-tea

To jeszcze obczaję te tooltypy i ikonkę. Dam znać.

Odpowiedz

SZAMAN
Redaktor

Re: Potrzebne testy programu wysłany: 2017-04-25 22:00

@r-tea

A więc tak:

1. tooltypy śmigają
2. jest czasami pewien problem z uruchomieniem się programu - aplikacja czasami nie startuje (raz na 20 przypadków nie pojawia się okno po kliknięciu na ikonkę), zwiększyłem stos, jest jakby lepiej, do zweryfikowania są jednak wersje klas MUI (napisz jakich program używa) w moim systemie. Taki brak startu powoduje bowiem niestabilności w całym moim MUI i konieczny jest restart systemu... Można by chyba także sprawdzić czy tak się dzieje z wszystkimi tooltypami - np. wyłączyć te lampki na dole, pamiętam, że tutaj było podejrzenie co do niestabilności na początku...
3. z ikonifikacją jest pewien problem, na tym obrazku widać prawidłową ikonę z opcji "minimalizuj do ikony na blacie", ale jest też dziwny biały kluczyk, gdy włączę opcję w MUI "minimalizuj do docka" (obok jest ikona Odyssey korzystająca z tej samej opcji), nie mam pojęcia skąd on się bierze - może Ty wiesz?

Odpowiedz

1 2 3 następna »

AmigaOS.pl