eXec.plMAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA
MAGAZYN UŻYTKOWNIKÓW KOMPUTERÓW AMIGA

sobota, 18. listopada, 2017, 14:42

Dodano: 2005-06-12 00:00, Autor: st, Kategoria: Oprogramowanie, Liczba wyświetleń: 980

A A A

AmiGift - powstaje wersja 2.0

AmiGift to program p2p dla AmigaOS. Trwają prace nad wersją 2.0, pojawiły się pierwsze obrazki - 1, 2, 3, 4.

Jak widać wersja ta ma nowe - ulepszone GUI, prawdopodobnie nie będzie korzystać z biblioteki ixemul i będzie obsługiwać m.in. sieci: BitTorrent, Direct Connect, OpenNap, OpenFT, Gnutella, FastTrack i Ares. Poszukiwani są betatesterzy (należy skontaktować się z Diego Casorranem), oraz osoby, które chciały by wesprzeć projekt finansowo.


Dodaj komentarz

SZAMAN
Redaktor

komentarz #1 wysłany: 2005-06-12 22:02

I kolejny bardzo dobry news, bardzo prawdopodobne, ze program bedzie ladnie dzialal pod 4-ka.

Odpowiedz

Prince
Czytelnik

komentarz #2 wysłany: 2005-06-12 23:22

Mimo że nadal brakuje ed2k to i tak się cieszę, że powstanie nowa wersja. Na starej już prawie nic nie chodziło.

Odpowiedz

rzookol
konto zablokowane
lub usunięte
Autor tego komentarza otrzymał czerwoną kartkę
Czytelnik

komentarz #3 wysłany: 2005-06-13 00:08 w odpowiedzi na komentarz #1

zauważyłem że na os4 depot jest poprawiona wersja rtgmaster.library - czy z tą wersją na os4 (na amigaone czy klassiku) dziala napal?

Odpowiedz

Mufa
konto zablokowane
lub usunięte

Czytelnik

komentarz #4 wysłany: 2005-06-13 09:43 w odpowiedzi na komentarz #3

zauważyłem że na os4 depot jest poprawiona wersja rtgmaster.library - czy z tą wersją na os4 (na amigaone czy klassiku) dziala napal?

Na AONE Napalm wczytuje się do pewnego meomentu, ale sam ekran rozgrywki nie działa, coś podobnie jak w Exodusie. Być może sprawę poprawi Petunia, w Exodusie ponoć poprawiła.

Odpowiedz

Konrad Bielski
Redaktor

komentarz #5 wysłany: 2005-06-13 10:08 w odpowiedzi na komentarz #4

Być może sprawę poprawi Petunia

Petunia ma gorszą kompatybilność od emulatora interpretowanego i zawsze będzie miała gorszą. Popatrz na wyjaśnienia Almosa na stronie Petunii.

Naprawdę rzadko się zdarza, że jakiś program nie działa z winy wbudowanego w system emulatora 68k. Zazwyczaj przyczyna leży w innym miejscu. A już na pewno w przypadku gier nie doszukiwałbym się winy emulatora.

Odpowiedz

winko
konto zablokowane
lub usunięte
Autor tego komentarza otrzymał czerwoną kartkę
Czytelnik

komentarz #6 wysłany: 2005-06-13 18:50 w odpowiedzi na komentarz #5

A już na pewno w przypadku gier nie doszukiwałbym się winy emulatora

No jakze by inaczej...

Odpowiedz

Konrad Bielski
Redaktor

komentarz #7 wysłany: 2005-06-13 19:34 w odpowiedzi na komentarz #6

No jakze by inaczej...

Masz jakieś doświadczenie w testowaniu programów 68k pod AmigaOS 4, którym byś się chciał z nami podzielić?

Odpowiedz

baderman
konto zablokowane
lub usunięte

Czytelnik

komentarz #8 wysłany: 2005-06-13 21:37 w odpowiedzi na komentarz #7

Masz jakieś doświadczenie w testowaniu programów 68k pod AmigaOS 4, którym byś się chciał z nami podzielić?

Myślę, że kolega chciał zasugerować, że zbytnio wierzysz w nieomylność Twórców Aos4 [MSPANC ], co może nie do końca korelować z rzeczywistością (przy całym szacunku dla tychże Twórców).

Odpowiedz

Konrad Bielski
Redaktor

komentarz #9 wysłany: 2005-06-13 21:58 w odpowiedzi na komentarz #8

Myślę, że kolega chciał zasugerować, że zbytnio wierzysz w nieomylność Twórców Aos4

Moje stwierdzenie oparłem na podstawie swojego doświadczenia w testowaniu oprogramowania 68k pod systemem AmigaOS 4 oraz wyników testów ponad setki innych betatesterów tego systemu przeprowadzonych w ciągu ostatnich kilku lat. Nie sądzę, żeby Twój kolega swoimi sugestiami mógł w jakikolwiek sposób uzupełnić moją wiedzę na ten temat.

Odpowiedz

winko
konto zablokowane
lub usunięte
Autor tego komentarza otrzymał czerwoną kartkę
Czytelnik

komentarz #10 wysłany: 2005-06-14 00:41 w odpowiedzi na komentarz #9

Hehe, jak zwykle wiele okazji do smiechu na execu: Bo jesli Ty musisz wyjasniac uzytkownikowi AOS4, ze: Petunia ma gorszą kompatybilność od emulatora interpretowanego i zawsze będzie miała gorszą to co w tym dziwnego, ze ktos kto nie jest posiadaczem tego systemu ma jakies watpliwosci. Po za tym, to przeciez emulator, chyba wiadomo do czego sluzy? Problem polega na tym, ze dla Ciebie sam fakt tego, ze jest to emulator w systemie AOS4, usprawiedliwia jego niedociagniecia. Hej, to tylko system operacyjny, bardzo fajny zreszta ale to nie znaczy ze nie ma wad. Wiec dlaczego od razu tak nerwowo?
Tak na marginesie, czy naprawde nie wiesz do czego sluzy formy grzecznosciowe typu "kolega"?

Odpowiedz

Konrad Bielski
Redaktor

komentarz #11 wysłany: 2005-06-14 07:10 w odpowiedzi na komentarz #10

Bo jesli Ty musisz wyjasniac uzytkownikowi AOS4, ze: Petunia ma gorszą kompatybilność od emulatora interpretowanego i zawsze będzie miała gorszą to co w tym dziwnego, ze ktos kto nie jest posiadaczem tego systemu ma jakies watpliwosci.

Mylisz dwie rzeczy:

Petunia będzie miała gorszą kompatybilność ze względu na użytą technologię JIT. Szczegóły na stronie Almosa - przeczytaj sobie.

Po drugie napisałem, że nie każdy brak kompatybilności z programem 68k wynika z wady emulatora.

Problem polega na tym, ze dla Ciebie sam fakt tego, ze jest to emulator w systemie AOS4, usprawiedliwia jego niedociagniecia.

Problem to masz Ty i polega on na tym, że nie rozumiesz, że gdy program 68k nie działa pod AmigaOS 4 to nie znaczy to, że winny jest emulator procesora 68k. Program może nie działać ze względu na zmiany w takich modułach jak kernel, dos.library czy wielu, wielu innych.

Nie znaczy to też, że te moduły mają niedociągnięcia - po prostu system się zmienia i część starych programów nie będzie działać.

Przed nami są kolejne zmiany w systemie, które prawdopodobnie wykluczą następne programy 68k z działania pod AmigaOS 4, ale zapewnią lepszą ochronę pamięci. Źle to czy dobrze, że AmigaOS 4 idzie w takim kierunku? A to już temat do innej dyskusji.

Odpowiedz

Nowar
konto zablokowane
lub usunięte
Autor tego komentarza otrzymał czerwoną kartkę
Czytelnik

komentarz #12 wysłany: 2005-06-15 10:00

O! Dawno mnie tu nie bylo...Jezeli AmiGift rzeczywiscie bedzie obslugiwal DC i ruszy na OS3.x to wielki szok ! No ale poki co nie nalezy wierzyc w gruszki na wierzbie (choc w tym przypadku sa to gruszki na jabloni), tylko w gruszki na stole

Odpowiedz

AmigaOS.pl

Polecamy
Najpopularniejsze
eXec blog

Świat poza Amigą: